Webprofis is een Forum waarin je vragen kunt stellen die webgerelateerd zijn. Heb je vragen over of problemen met je Webpagina, HTML, CSS, Javascript, PHP of andere client of serverside scriptingtalen? Stel ze dan gerust op dit forum. Op dit forum zijn een aantal vrijwilligers actief die u graag met uw vragen willen helpen en u waar mogelijk een passend antwoord aanbieden. Hebt u zelf veel ervaring en kennis met betrekking tot het bovenstaande? U bent van harte welkom om uw kennis met anderen te delen!

We hopen dat eenieder op dit Forum een leerzame ervaring mag opdoen.

Team Webprofis

unicode karakters niet weergegeven

bewerkt di 2 dec 2014 in Stylesheets Posts: 879
Ik probeer een unicode karakter te gebruiken voor een permalink.
Ik wil voor de datum (die in de classe Permalink staat) dat unicode karakter plaatsen.
In de css file doe ik dat als volgt:

a.Permalink:before {
content: "🔗"; /* link symbool */
color: #428bca;
}
In de css file heb ik bovenaan staan:

@charset "utf-8";
In de html file staat:

<meta charset="utf-8">
En de css file heb ik opgeslagen als utf-8 encoded.
Maar nog steeds geeft ie &#128279 als plain text weer.

Zie ik iets over het hoofd?
forum.webprofis.nl/discussion/273/www
Getagd:

Reacties

  • PMPosts: 732
    Kijk eens naar de Sprite in je rechter menu bv. Categorie??n daar zie je precies hoe ze het hebben gedaan.
    Fontawesome wordt geladen, dus met bv fa fa.tag zou je een icon moeten zien.
    If it's not fun, you're not doing it right!
  • bewerkt di 2 dec 2014
    PMPosts: 879
    Dan zou ie zo moet werken wat ie helaas niet doet:

    a.Permalink:before {
    content: "\f02c";
    color: #428bca;
    }
    Je ziet wel een blokje maar niet het icoon, terwijl de categorie iconen in de re kolom op precies dezelfde wijze gegenereerd zijn
  • PMPosts: 732
    probeer eens:


    a.Permalink:before {
    content: "\f02c";
    color: #428bca;
    display: inline-block;
    min-width: 1em;
    font-family: FontAwesome;
    font-style: normal;
    font-weight: 400;
    text-align: center;
    }



    If it's not fun, you're not doing it right!
  • bewerkt wo 3 dec 2014
    PMPosts: 879
    Yep die werkt! Good job
    font-family: FontAwesome moet erbij staan; net getest als ik hem even weggehaal en dan verdwijnt het icoon
Login of Registreer om te reageren.